Froyo 2.2 Update required for Skype on this phone

...but is that available on all networks?

Add a comment

JanSt / MOD  Jan. 11, 2011 at 18:54

Do you mean IS Skype available on all networks or IS Froyo for the Galaxy S? And: is your Galaxy network-locked/-branded? If it is, yes, it's up to the networks. Why do you need Froyo for Skype, by the way?

thesleeper  Jan. 15, 2011 at 05:35

Yeah. Phone is locked and network only has 2.1 right now. Am going to unlock it as Skype does not work on 2.1 for many of the Samsung phones including this one.

JanSt / MOD  Jan. 17, 2011 at 17:55

You need to get on to your network. Or you need to root the phone and flash it with Froyo-ROM. Check OR ask a trusted phone repair shop (will ruin warranty)

thesleeper  Jan. 18, 2011 at 16:11

I'm gonna' root'n'flash rather than wait on my network.

MrRatPants  Jan. 18, 2011 at 16:17

I was reading that there are some awesome rooting tools that you can set it back to 'unrooted' if you ever need warranty work done. Not sure about flashing back to stock firmware... I know it can be done on some phones.

bigmo7  Jan. 18, 2011 at 17:12

Yeah you can flash back to stock firmware and unroot the phone if you need warranty work done. Chances are unless it's hardware problems that you won't need the warranty as the SGS is really extremely hard to brick. Also don't wait for your network, get on XDA and get the FW. It's on 2.2.1 now with a new FW out this month.

JanSt / MOD  Jan. 18, 2011 at 17:38

MrRatsPants and bigmo7,
you're right, the "One-Click Root/Unroot" app for the Galaxy S allows you to easily remove the root. You can find it => However, the phone will still be network-locked ;)

bigmo7  Jan. 18, 2011 at 17:41

The SGS has to be one of the easiest phones on Android to unlock, there's even an app for it on the market. ;)

thesleeper  Feb. 7, 2011 at 19:50

Running Skype now on my 2.2-updated phone. It's da bomb.

thesleeper  Feb. 7, 2011 at 19:53

I'm really happy now. This is a great phone, but the lack of Skype was a downer for a while 'til I got my Froyo.

JanSt / MOD  Feb. 7, 2011 at 20:13

Skype annoy me quite a bit. The way they act as though "sadly some OSs/handsets aren't supported, yet" as though God was a bit willy nilly with Tech... and yet you can walk into a Three store and there are all the 'unsupported' phones with, yep, Skype messengers...


You don't need an account to comment. Just enter your email address. We'll keep it private.