iOS 8 apps - iOS 8 as a minimum requirement?

Am I missing out on any apps by not upgrading to iOS 8? Are there any apps that have iOS 8 as a minimum requirement?

Add a comment
 1 comment

JanSt / MOD  Nov. 25, 2014 at 15:34

Yes, some iPhone and iPad iOS apps require a minimum of iOS 8. Apple's own apps - such as Garageband for example. I'm pretty sure I noticed a few others, also. But I cannot think of the names.
Occasionally, the Appstore or iTunes shows a popup saying the new version of the app is not compatible, but that you can install an older version - I think that happened to me with Goodreader and iOS 7, for example. But the vast majority of apps haven't even been updated to iOS 8, and are quite happy with iOS 7 and earlier.


You don't need an account to comment. Just enter your email address. We'll keep it private.