wendygwendy

I have a tilt 2 from the states, but can't find a mobile provider to support the internet. I have o2, but they say they don't support it. Any ideas?

Most Useful Answer JanSt  May. 21, 2011 at 13:16

Nonsense! Its a wm device. You just need to add the O2 APN (internet access point).
=> On the Home screen, slide to the Settings tab and then tap Wireless controls. =>

On the Comm Manager screen, tap Data connection. =>

Somewhere there, you should be able to 'edit the APN' or 'add apn'...
The settings you need are:

APN (contract): mobile.o2.co.uk
APN (PAYG): m-bb.o2.co.uk
Username: web
Password: web

You may double-check the settings with someone on O2, but it's nonsense that they 'don't support' this or that phone. It's just a matter of adding the right settings. They just don't know how to do that ;)

You can also work your way through the old-fashioned winmo menus to go to settings - connections - connection manager and take it from there.

Add a comment
13 comments

JanSt / MOD  May. 21, 2011 at 13:16

Nonsense! Its a wm device. You just need to add the O2 APN (internet access point).
=> On the Home screen, slide to the Settings tab and then tap Wireless controls. =>

On the Comm Manager screen, tap Data connection. =>

Somewhere there, you should be able to 'edit the APN' or 'add apn'...
The settings you need are:

APN (contract): mobile.o2.co.uk
APN (PAYG): m-bb.o2.co.uk
Username: web
Password: web

You may double-check the settings with someone on O2, but it's nonsense that they 'don't support' this or that phone. It's just a matter of adding the right settings. They just don't know how to do that ;)

You can also work your way through the old-fashioned winmo menus to go to settings - connections - connection manager and take it from there.

ugriniwin26  Jul. 12, 2011 at 16:47

I have a tilt2 for USA as well and I have the same problem. I have service with talk mobile. They said they don't have settings for non-UK phones and no UK providers do. This seems like crap to me because the box it came in says "WORLD PHONE." When I turn it on the words “WORLD PHONE” displays on the screen. I figured since I travel a lot then I can use it where ever I go with a local sim. Now I am told that not ever thing on it works in the UK? Isn't that a bubble buster! I even took it to car pone warehouse where I got the sim and to geek squad. Still no luck. Any suggestions? Anyone?

JanSt / MOD  Jul. 12, 2011 at 17:54

The phone takes exactly the same internet settings as all other uk phones that do work on your network.
Often the network spew that sort of bull cause they cannot be arsed to research how those settings are entered! That is the only difference from phone to phone: where to enter the settings and how. Not the settings!
Just 'google' for the internet settings for your network, and figure out where to input them in your phone.

It is indeed a 'world phone'.

ugriniwin261  Jul. 12, 2011 at 20:04

The phone takes exactly the same internet settings as all other uk phones that do work on your network.
Often the network spew that sort of bull cause they cannot be arsed to research how those settings are entered! That is the only difference from phone to phone: where to enter the settings and how. Not the settings!
Just 'google' for the internet settings for your network, and figure out where to input them in your phone.

It is indeed a 'world phone'.
The phone takes exactly the same internet settings as all other uk phones that do work on your network.
Often the network spew that sort of bull cause they cannot be arsed to research how those settings are entered! That is the only difference from phone to phone: where to enter the settings and how. Not the settings!
Just 'google' for the internet settings for your network, and figure out where to input them in your phone.

It is indeed a 'world phone'.


Thank you. I will go searching now and see what I find.

ugriniwin26  Jul. 13, 2011 at 14:53

I did my research and got a lot of information but now I am stuck again. I cannot get online when I am done. Whenever I go back to check my settings my password changes from a short password (wap) to a long password like **************. The 3G connect shows on my screen but I get an error message saying "the server, while acting as a gateway proxy, did not receive a timely response from the upstream server it accessed ..."
I know the password has something to do with it but I don’t know how to stop it from changing. Any ideas?

ugriniwin26  Jul. 13, 2011 at 15:45

Well I don’t believe it for a second but I actually got internet using 3G. I use the talkmobile settings for GPRS which does not require a password. I have to use this a couple times to make sure it is for real and not just a one moment thing. I have been going around to my providers and "experts" for about a month and then accepted that it just will not work so I stopped trying until yesterday. JanST post really inspired me to go hunting for some answers. Thanks a million.

ugriniwin26  Jul. 13, 2011 at 15:46

. I am now going to try the settings for MMS because that one is not working properly. I can’t use instant messaging neither can I send or receive a picture message. This setting requires a password and I still have the password problem I mentioned earlier. If anyone has the slightest clue about preventing the password from automatically changing please please share.

JanSt / MOD  Jul. 13, 2011 at 16:15

Been looking around a bit myself (we don't have TalkMobile in Ireland)
Came across this threadbut it's almost a couple of years old, so the info may be out-dated?!

Also, have you tried leaving the password/username blank? Often, you do not actually need to enter those.

----------------------------------------------------------------

Setting type - MMS GPRS Account type - Talkmobile Pay Monthly Account type - Talkmobile Pay As You Go
Name of the MMS service (as it should appear on the handset menu) Talkmob MMS Talkmob PAYG MMS
MMSC-Address http://mms.talkmobile.co.uk/
servlets/mms http://mms.talkmobile.co.uk/
servlets/mms
Proxy IP Address 212.183.137.012 212.183.137.012
Proxy port for MMS connection 9201 (WAP1.x)
or 8799 (WAP2.0) 9201 (WAP1.x)
or 8799 (WAP2.0)
Access Point Name (APN) address talkmobile.co.uk payg.talkmobile.co.uk
Access-Point Username wap wap
Access-Point Password wap wap
Setting type - WAP GPRS Account type - Talkmobile Contract Account type - Talkmobile PAYG
Name of the WAP service (as it should appear on the handset menu) Talkmob WAP Talkmob PAYG WAP
Homepage URL http://wap.talkmobile.co.uk http://wap.talkmobile.co.uk
Proxy IP Address 212.183.137.012 212.183.137.012
Supported port settings for your standard and TCP/IP WAP service. 8799 for WAP 2.0
9201 for WAP 1.x 8799 for WAP 2.0
9201 for WAP 1.x
Access Point Name (APN) address talkmobile.co.uk payg.talkmobile.co.uk
Access Login Type (Automatic) (Automatic)
Access-Point Username wap wap
Setting type - Internet GPRS Account type - Talkmobile Contract Account type - Talkmobile PAYG
Name of the Internet service (as it should appear on the handset menu) Talkmob Internet Talkmob PAYG Int
Access Point Name (APN) address talkmobile.co.uk payg.talkmobile.co.uk
Still cannot use Internet or MMS?

Your handset is unable to find the correct settings to access the service. You need to ensure that Talkmobile settings, once downloaded, are saved as default. Some handsets have preloaded settings of other mobile operators and it is recommended that these be deleted. Alternatively, call 5888 from your Talkmobile phone and speak to our customer services team.
------------------------------------------------------------------

Oh, and lastly, when you type the password "wap"...it will look like a longer password => "**********" It doesn't mean it is changed to a longer password. It's just made to look like a longer word for security! ;)

ugriniwin26  Jul. 13, 2011 at 22:46

I have been using those same settings for the MMS but I am probably messing up some where. Thank you so much for telling me that bit about the password because here I was stressing over it. Well now I know that is not the issue.

To answer your question. When I try it without the password for the MMS it looks like it is connected but when I try instant messaging that same screen pops up requesting username, password and domain name

JanSt / MOD  Jul. 14, 2011 at 12:14

ugriniwin,
I wonder if now that you seem to have the settings a call to cc/tech support might help? Now and again I experiment with 'unsupported' phones on Vodafone Ireland, and mms seems to require activation on their end ever so often...

meganhowcroft1  Aug. 16, 2011 at 20:14

i was wondering where you bought it from because i have been looking for this phone and i cant find it anywhere im also on o2. how much was it aswel? x

JanSt / MOD  Aug. 17, 2011 at 10:30

meganhowcroft1
The Htc Tilt/Tilt2 were US releases http://www.htc.com/us/products/tilt-2-att/
The closest Euro equivalent was/is the HTC HD Mini... and even that is hard to find - oddly enough. It was a cool little worker http://www.gsmarena.com/htc_hd_mini-3163.php

blizzard7  Aug. 17, 2011 at 11:50

@JanSt
Yup, I was also a bit of a fan for the HD Mini. It was a bit on the slow side and HTC Sense did seem to duplicate many functions it already had but it felt really good in the hand. I think HTC should've pushed the Gratia (with some better specs) which is based on the same form factor, as their low-end phone instead of the HTC Wildfire S.

Email:

You don't need an account to comment. Just enter your email address. We'll keep it private.

Comment: